Filter Returns Like Records Instead of Exact Records

The grid we have created has the following values in a column:

 Core Building

When choosing ORE in the filter it returns both records instead of just ORE.

Is this the expected functionality?


Using 3.6 Pro

This is the expected behavior.
Please, try to use “#select_filter_strict” instead of “#select_filter”.

Thanks for the quick response. That worked.

I am having a similar issue except that I am using #connector_select_filter and when I try #connector_select_filter_strict it doesn’t work.

So I then realized that there wasn’t actually a method for #connector_select_filter_strict.

So I found the code for #connector_select_filter in connector.js and tried to copy/paste it to add a method for strict:

dhtmlXGridObject.prototype._in_header_connector_select_filter_strict=function(t,i){ this._con_f_used[i]=2; return this._in_header_select_filter_strict(t,i); }

This does not seem to work…so I’m obviously missing something.

In case of using the connector’s filters: unfortunately there is no such server-side strict filter.
You will have to create your own custom filtering logic using the beforeFilter event: … lter_event