а

Not getting or saving data to sql


#1

Following the documentation in getting started (https://docs.dhtmlx.com/gantt/desktop__howtostart_dotnet.html). I’ve implemented everything as written. Other than a ton of warnings related to the dhtmlxgantt.js file, I’m getting no errors. The index view is now pointing to the https://cdn.dhtmlx.com/gantt/edge/dhtmlxgantt.js location rather than the local js scripts.

I ran the app, and tried creating a few tasks and links, but nothing was being saved.

I then manually populated the Tasks table to see if it was even reading from the database, which it is not.

There were several errors in that guide, (e.g. within the link class defining the properties as Source, but within the LinkDto referencing to it as SourceTaskId). I’m not seeing any issues with the controllers, so I’m unsure as to why it wouldn’t get the data. It feels like something is missing.


#2

Hello Shane,
Please, open the network tab in the web console and check if there are any error messages when you load the data and when you create or update a task.
If you don’t see any requests when adding a task, then there is something wrong on the client-side in Gantt. If there are requests with the errors, we need to check the error messages.

You can also check the ready demo that has all the necessary settings, and it should work correctly when you run it:


#3

I’ve spent some time looking for the web console and network tab. I know the Network tool is showing as not applicable in the performance profiler. I’m not seeing anything that will allow me to check the requests.


#4

Hello Shane,
I tried to run our official demo and created an application by following the guide - the tasks are correctly loaded, and all the changes are saved. I didn’t correct anything in the guide, just created views and controllers - everything that the guide required, and just pasted the strings from the guide.
After running Gantt, Visual Studio creates a database with tasks. If you don’t see tasks, it means that the database has not been created yet. Probably, you need to wait up to 5-10 minutes. After that, you will see tasks in the chart, and if you create a task, it should be saved to the database.