Auto scheduling

I am trying to add auto_scheduling but I am feeling it is not working as expected.

I am using angular 7 and the dhtmlx 6.1.3 pro version and I am not able to change dates with the lightbox when I add auto_scheduling.

Here is the code (as i can’t make a snippet with the pro version I’ll let you try it with this code):

selector: ‘app-root’,
template: ‘

export class AppComponent implements OnInit {
@ViewChild(‘ganttHere’) ganttHere: ElementRef;

ngOnInit() {
gantt.config = {
fit_tasks: true,
auto_scheduling: true,
auto_scheduling_strict: false
data: [
{ id: 1, text: ‘Project #1’, start_date: ‘01-03-2019’, duration: 3 },
{ id: 2, text: ‘Project #2’, start_date: ‘05-03-2019’, duration: 2 },
{ id: 3, text: ‘Task #1’, start_date: ‘08-03-2019’, duration: 2 }
links: [{ id: 1, source: 1, target: 2, type: ‘0’ }, { id: 2, source: 2, target: 3, type: ‘0’ }]

Hello Oouassim,
Thank you for reporting about that.
Looks like it can be reproduced even in our samples.
I added it as a bug in our tracker. It will be fixed in the future. I cannot give you an ETA, but I will notify you when the fix is ready.

So no need to expect it to be fixed on the 6.2 version ? Or you can’t say when it will be fixed ?

Hello Ouassim,
It might be fixed earlier, but I can’t promise that.

Looks like, the bug there is not only that Gantt doesn’t change the dates, but that it doesn’t inform users about constraint dates, and that the behavior in the lightbox is different from the manual drag.
When autoscheduling is enabled Gantt sets constraint dates to a task when you move it in the timeline. Linked tasks have “ASAP” constraint by default:
So when you try to change the start_date in the lightbox/inline editor, it violates the constraint rule, so Gantt doesn’t allow changing that. If you change the constraint type to “Start No Earlier Than”, you will be able to move the task to a new date.

So now, as a workaround, you can add the constraint section in the lightbox sections:

gantt.config.lightbox.sections = [
	{ name: "description", height: 38, map_to: "text", type: "textarea", focus: true },
	{ name: "constraint", type: "constraint" },
	{ name: "time", type: "duration", map_to: "auto" }

Here is an example:

1 Like

I was about to come to tell you that with auto_scheduling_compatibility = true the update with the lightbox were working and I saw your post updated.

So yes it is probably related to the constraint. I will try your workaround.


Hello Ouassim,
The bug was fixed in the 6.1.7 version:
You can test that it is no longer reproduced in the following sample:

1 Like

I am using different calendar to each task. Each task is having different non working days, if i will do auto schedule with relation ship start to start and start to finish. Auto schedule is not working as expected. We have created a snippet.

In the above snippet, Task #2.1 has 3 non-working days, Task #2.2 has 2 non-working days

Even though Task #2.2 is connected to Task #2.1 with a Start to Start link, the start date of Task #2.2 is shifting by one day later than the start date of Task #2.1

Hello Amit,
We are aware of the bug.
Unfortunately, I cannot give you any ETA or provide a workaround.
But I will notify you when the bug is fixed.

Hello Amit,

The dev team fixed the bug with the auto-scheduling and different calendars: