Changing the timescale part of the task is not shown on the Gantt chart


#1

“data”:[
{“id”:“10”, “text”:“Project #1”,
“render”: “split”, “start_date”:“02-04-2019”, “duration”:3, “order”:10,“progress”:0, “open”: true},
{“id”:“1”, “text”:“Task #1”, “start_date”:“02-04-2019”, “duration”:1, “order”:10,“progress”:1, “parent”:“10”},
{“id”:“2”, “text”:“Task #2”, “start_date”:“06-04-2019”, “duration”:1, “order”:20,“progress”:1, “parent”:“10”}
],

gantt.config.scales = [
{ unit: ‘day’, step: 1, format: ‘%Y-%m0%d’ },
{ unit: ‘hour’, step: 1, date: ‘%H’ }
]
According to the above settings of Gantt chart, tasks with id = 2 cannot be displayed under the set timescale or smaller timescale.


#2

Hi!

Thanks, I’ve reproduced the issue and confirmed the bug.
I’m adding it to our issue tracker, we’re going to investigate it in the nearest time and will give you an update as soon as we have something new.


#3

Hello Ella,
It happens because the parent task doesn’t have the project type. So, the smart rendering hides Task #2 because Project #1 is not visible on 06-04-2019.
As a workaround, you can disable the smart rendering:
http://snippet.dhtmlx.com/4283b5bf7
or add the following property to Project #1 task:

"type":"project"

http://snippet.dhtmlx.com/72c2b44ff

That bug will be fixed in future versions.


#4

Hello Ella,

The dev team fixed the bug when Gantt hid the split task when its parent didn’t have the project task type:
https://docs.dhtmlx.com/gantt/whatsnew.html#701
You can see how it now works in the following snippet:
http://snippet.dhtmlx.com/7469c747f