CheckBox not work when load data.

I created a form that reads data from a MySQL db, nela being charged are not assigned values to the checkbox. Instead the radio buttons work perfectly. In operation save the values are correctly transferred to the server.

XML Code:





MySql db:
CREATE TABLE rights (
id INT(10) NOT NULL AUTO_INCREMENT,
user_id INT(11) NOT NULL DEFAULT ‘0’,
organizer VARCHAR(1) NOT NULL DEFAULT ‘0’,
organizerRW VARCHAR(1) NOT NULL DEFAULT ‘0’,

DB connection:
$formConn->render_table(“rights”,“user_id”,“organizer,organizerRW,addressbook,addressbookRW,
monthly,monthlyRW,employment,employmentRW,printing,administration”);

Code:
contactsGrid.init();
contactsGrid.load("…/php/utenti.php");
contactForm = dhxLayout.cells(“b”).attachForm();
contactForm.loadStruct("…/dhtmlxToolbar/common/xml/utenti_diritti.xml");
contactsGrid.attachEvent(“onRowSelect”, function(rID,cInd){
contactForm.load("…/php/update_conn_admin_rights.php?id="+rID);
})
myDataProcessor = new dataProcessor("…/php/update_utenti.php?"); //lock feed url
myDataProcessor.init(contactsGrid); //link dataprocessor to the grid
var dpf = new dataProcessor("…/php/update_conn_admin_rights.php?");
dpf.init(contactForm);
}
I apologize for my English is not quite perfect
Best Regards

Try to enable logs - it’ll allow to get information about errors:
$formConn->enable_log(“log.txt”);
$formConn->render_table(…);

Here we have attached the form 2.6 library that contains fixes for all known bugs:
viewtopic.php?f=17&t=17304
Possibly it’ll help to resolve the problem.