Combobox load xml error character


I’m using the dhtmlxcombo with filtering mode, where i load the content trough a php file. However, i get the load xml error. when i open the php file. it indicates that whitespace is not allowed at this location. I only get this error in one string where the string contains the “&” character in the combo list.

the following string indicates an whitespace error after the “&” character

Aann.mij. De Vries & v.d. Wiel BV

how to solve this problem?

kind regards,


The & is prohibited by XML rules, it must be replaced with &
There are two ways
a) direct escaping
    Aann.mij. De Vries & v.d. Wiel BV

b) using CDATA

Thnx! it worked like a charm.


I’m again fasing a problem with illegal chracters in the combobox. I’m using filteringmode and loading data from a php file. The problem i’m fasing is that when i replace strings containing ‘&’ with the & it does not show any load xml error however, when i submit the form it does not pass the option value. i tried checkking the following variable NAME_new_value, but it displays the value true. From what i have read this mean that the value typed does not match any item in the list. But in my case i select the option using the arrow keys which is already in the list. Can u please tell me what a possible soloution to this is?


There are two possible solution

a) use double escaping for & char in XML ( first escaping - to accommodate  XML rules, second for correct HTML rendering )

        A & B

b) update dhtmlxcombo.js , comment line 197


I’m getting a load xml error when i enter a single quote in the dhtmlxcombo. Can you tell me a way to fix this?

Kind Ragrds,



could you please provide the example of the problematic xml.


please see the following situation.

<option value=“28>Akzo Nobel Base Chemicals R’dam</option>

when I type the single quote i get tje load xml error. I use php file to load the data from the database.

King regards,


There shouldn’t be issues with this xml…

Try to place the text into CDATA tag. Possibly it’ll help:

It still doesn’t seem to fix the problem. Please find attached a sample of the xml file.

Kind regards,

Nasir (1.52 KB)

locally the same xml works.We have attached the sample. (17.5 KB)

it seamed that i had old version of the .js files.