Data validation with numbers invalid


I’ve found that making a data validation and setting all items as numbers will cause the selection of an item to show ‘Invalid value’.
This is due to the items being saved as string and when selecting a value it’s of type number, thus not answering truthy to ===.
I tried manually setting the value selected as string but the same result happens.

Is there something I’m missing?

Could you please, clarify your issue with some sort of the example or a snippet, as locally the described scenario seems to work well for me. Please, refer to the following snippet:


The issue happens when creating a validation from the UI, not from code.
This is a screen capture of the issue I’m experiencing, hope it clarifies it.

Thank you for your report. The problem is confirmed.
We’ll try to fix it in one of the future updates. I’ll inform you here about any progress on this issue.


You reported problem was fixed in the latest dhx.Spreadsheet update (v5.0.1).
Please, try to update your dhx.Spreadsheet build to get that fix.
Thank you for your report.