dhtmlx text input cursor bug in FF


I’m thinking about it for about 4 hours, and i couldn’t work it out yet.
If I place a text input field () on anywhere in the tabbar’s content area, the cursor (for writing) is not displayed in FF, but in IE and Opera.

I’ve tried to change and disable every styles, analyze it in Firebug, and I’ve tried almost everything, but the only thing I have found, is that the problem only exists if I place the textfield into the tabbar.
But I either did not find any relevant information or anything what could cause this problem.

please help me.

Is problem appears for latest js|css files?

I can’t reconstruct issue locally - but by description with is known FF issue.

Here is the example where the text cursor disappears -

  And here it is visible again -


  As far as I understand the bug is triggered by “overflow:auto” or “overflow:scroll” rules on the overlapping div below the input box and can be corrected by another div around the input box with “overflow:auto” or “overflow:scroll”.

dhtmlxtabbar.zip (898 Bytes)


thank you for your answer.
I am using the latest package.
I have tried many things, disabling styles, and adding or removing overflows a lot of places, but nothing helped.
I am using a layout div (cause fe. for padding) for a tab and two other for the content.

In firebug I realized, that if I disable this overflow in the tabbar’s css, than the cursor appears.

.dhx_tabcontent_sub_zone {

but I don’t know, how to override successfully this property without overwriting your code.

Any followup on this subject?
I have the same problem, very anoying.


As mentioned earlier problem caused by bug in FF rendering engine, there are only two solution

a) wrap you input with “div” on which “overflow:auto” set
b) remove all overflow styles from dhtmlxtabbar.css - it will not kill functionality, just block any scrollbars in tabbar

If you can isolate problem as separate sample, send it to support@dhtmlx.com - probably weI will be able to show workaround on it.

It is solving the problem of Cursor, but it showing scrollbar even after giving overflow : “hidden” and “auto” values. Please help.