dhtmlxGrid addRow does nothing?

I have a dhtmlxGrid which shows a few rows (loaded from the server); I click on something, and I want to create a new, (maybe empty) row using JS on the client;
basically it’s something like:
I inserted test-values to make it clear, as it doesn’t work with this fix data (as obviously it doesn’t work with dynamic data read from client-JS-variables)
101 is the unique ID
the second string should be the values of the 4 columns (the first columns is not visible, the second column is a type “coro”, the 3rd and 4th columns are types “edn” with format-masks);
I also tried this second string with “” or “101,” but nothing changes;
after this JS-command the scripting stops and nothing works anymore on the page;

  • what could be the problem? are there problems with certain types? (I’m using coro for the
    first time)
  • is there a possibility to debug this in any simple way? it would be fine to get an errormessage
    pointing out what is not working … but at the moment there is no dhtx-message and no
    JS-message at all

the problem seems to be the following:

  • you cannot add rows while you are just handling the event “onEditCell”

in my case there was the event attached to the grid
when Stage=0 and other conditions applied, I called a function, which tried to add
the rows
the grid simply did nothing!


in this function I don’t add the rows directly, but instead of that I call a function with a
meanwhile the handlich of the onEditCell-event is finished and the timeout is done, so
AddGridRow starts and adds correctly the new row