dhtmlxGrid not supported for firefox 4?

I am using dhtmlxGrid v.2.0 Professional edition build 81009/81107 !EVALUATION

We are using firefox 4. Got a exception mentioned below

Error: uncaught exception: [Exception… “Component returned failure code: 0x804b000a (NS_ERROR_MALFORMED_URI) [nsIXMLHttpRequest.open]” nsresult: “0x804b000a (NS_ERROR_MALFORMED_URI)” location: “JS frame :: … xcommon.js :: <TOP_LEVEL> :: line 23” data: no]

tried to debug but failed to get any clue. Pls help

You need to update your dhtmlxGrid version.
If issue still occurs for you - please provide any kind of sample or demo link where it can be reconstructed.

I upgraded the dhtmlxGrid to 2.6, but still same error exist on different line no know on 193(same code). Since my application is big I can’t provide the sample code.

I visited on dhtmlx site and tried to browse the samples using firefox 4 but somewhat same error come for sample dhtmlx.com/docs/products/dht … aging.html. So know can anyone help me to get across the error shown in Error Console of firefox 4.

thank you.

Can you please send us screenshot of page where issue occurs including FireBug console. Also can you please send us screenshot of FireFox version

Thanks Sematik,

I am sending three attachment

  1. Output.png is the correct behavior in firefox 3. if we click on the user on Application View on left pane then user and its properties displayed in right.
  2. error.png that is coming in firefox 4.
  3. firefoxVer.png

I had already posted the version of dhtmlxGrid that I am using, the same error comes on the latest dhtmxGrid 2.6 ver.

unfortunately we can’t help you without sample of your code.
please provide any kind of sample or demo link where it can be reconstructed.

:smiley: Now ploblem is solved.

there was bug in our code what happend was when we create the dynamic url we was using location.port. so while forming the url extra port got added to the url ‘:8443:8443’ that is overlook by the previous firfox versions. but firefox 4 thows the exception that malfunction uri.

Since it was supported by older version. we overlook the issue and tought that problem is somewhere else.