dhtmlxtoolbar can not read property "enabled"

I download the last dhtmlxtoolbar
I have a error when I try to execute
the error is this: Uncaught type error: Cannot read property ‘enabled’ of indefined
the line is into the function dhtmlXToolbarObject.prototype._sliderObject second line this.state = data.enabled:

Please helpme with this problem

I attached the image error


We need completed demo to reproduce it and help you
docs.dhtmlx.com/doku.php?id=othe … leted_demo

Hi Darya

I followed the instructions mentioned and I have the same error.
I download Toolbar Standard Edition v.3.5 and I work with Visual Studio 2012 and Asp.net 4.
I you view the image load the buttons in toolbar but the function is wrong and the console show me the error

Can you provide us you demo? We need to see your code and files you use.
docs.dhtmlx.com/doku.php?id=othe … leted_demo

Hi Darya

when I preparing the sample program was presented this error

Uncaught Reference Error: dhtmlx is not defined.

I Attach the program and image
ToolBarDhtmlx.rar (212 KB)

We need a demo withot server scripts.
docs.dhtmlx.com/doku.php?id=othe … leted_demo


I attach the demo
If you view in the navigator the javascript console this error:
Uncaught ReferenceError dhtmlx is not defined: line 2961
CompleteDemo.rar (53 KB)

I replaced your shtmlxtoolbar.js file with mine and it fixed the issue.
This file in the attachment.
dhtmlxtoolbar.rar (11.4 KB)

Hi Darya

I copy the file that you send me to mine demo but I have the same error:
Uncaught ReferenceError: dhtmlx is not defined

I attach the demo with your file and the image error.
CompleteDemo.rar (48.8 KB)

What browser do you use?
My result in all browsers:

I use google Chrome

Maybe I probe with firefox vs. 16.0.2, Internet Explorer vs. 9 and google Chrome vs.23.0.1271.95 and the same error


I Probe in google chorme vs. 23.0 ,firefox vs. 16.0.2 and internet explore vs. 9.0 and the same error.


I understood! It is necessary to use the correct order of files: dhtmlxcommon.js is always goes the first.



And use right folder names" your folder is “Codebase” and you try to go by path “codebase”…

Thanks Darya
I use the order that send me and I don’t have error


You are welcome