Enable User (myself) for adding/editing events

I know this is very simple and I can edit it somewhere but I can’t seem to find the setting.
I am always in read only mode. I can’t just double click to create a new event. :slight_smile:
I am thinking I need to enable myself to be able to write to the calendar somewhere in the WP CP.

Where exactly am I supposed to be able to edit this calendar. So far I have just traveled to the page it creates on install to try the adding of an event. Maybe I need to go in through wordpress CP and then click preview page or something???

Thanks in advance for your help!
Sara Murray

Hi there,

I’m not sure if i understood your question, but, try this:

Take a look at the source code, and find the following line:

scheduler.config.readonly_form = true;

…and comment that line to be able to create/edit events:

//scheduler.config.readonly_form = true;

Good luck

If you could tell me what file that code would be in that would help a lot. I went into the wp-content/plugins/event-calendar-scheduler/ to find that there are several PHP files in there to look through.

Thank you

Hello there,

On the page “scheduler_init.php”, look for the following line:

$final .= "scheduler.config.readonly_form = true;

hope that this can helpful(sorry my bad english too)



am always in read only mode. I can’t just double click to create a new event

Did you set the option “Show posts as events” ? If this option is set, the scheduler will be in read-only mode.

Thank you! I knew it was going to be something easy that I had just overlooked.
Thank you to Jackssl as well. (You’re English is just fine by the way)