Events are displayed twice after edit.

I have found an issue in dhtmlx scheduler. The issue is - if your site which is using dhtmlx scheduler is hosted in different timezone let say PST (-8). and you are accessing the scheduler from other timezone let say IST (+5.30) and creates a recurring events for two days. and when you edit the event for one day only as “This event only” and not “the series”. that event is displayed twice on scheduler means it show both events (parent and child) for that day.

does anybody face this issue? please let me know if any body has the solution of it.

try enabling this config

var scheduler = new DHXScheduler(); ... scheduler.Config.occurrence_timestamp_in_utc = true;

we don’t need to show scheduler data in user’s browser timezone. we process the scheduler data based on the user’s preferred timezone and then give it to scheduler to display. data stored in database is correct when a user edit an event. but it displays the edited event twice side by side. i.e scheduler is showing both event parent (before edit) and child(created after edit).

this property should only affect the format in which occurrence is stored in the database, it won’t change the way events are displayed. Have you tried enabling it, does it fix the issue?

hi Aliaksandr,

it works only if we give data in UTC to scheduler. but if we process data according to the user’s preferred timezone and then give that data to scheduler. event is shown twice.

Any idea why this is happening and how it can be resolved?


can you please provide some kind of demo where we could check the issue?
Usually ‘occurrence_timestamp_in_utc’ resolve such problem and does not interfere with other settings since it only affects the values of event_length property of event.

Can you please clarify what do you mean by this? Do you alter date values of calendar events before loading them into scheduler?

Thanks Aliaksandr,

problem resolved. issue was timestamp was not calculated correctly. we correct that and also
set scheduler.Config.occurrence_timestamp_in_utc = true;
it resolved the issue.