Events not showing on companies network?

I set up scheduler in joomla with the map extension
Works fine on my home pc and a friends pc
For some reason the events won’t display on the companies network of Mac computers
Everything else is displaying but just not showing any events
I got it to work yesterday on one Mac but after a reboot it wouldn’t work again
I didn’t alter any network settings at all just went into pop up blocker and disabled it
And then it showed all events
Not today , disabled pop up blocker and they still wouldn’t show.
So I don’t think that was it . But for some reason it showed the events for the period before the reboot. They have one xp pc there and the problem was the same.
I tried on my Mac laptop with my wireless dongle and it worked fine. I am now at home and tried it on an iPad even and it’s fine.
I’m thinking something is being blocked but I don’t understand how I could get it to work on one after playing with a few I missing something?
Btw this happens on every computer , about 15 of them
Funny thing is if I come to the dhtmlx demo pages on the work computers everything works fine
So I’m confused… Any help out there as I’m stumped

There are two kinds of possible problems

a) caching - if scheduler loads some data , but not the one which you expects to see - it hardly possible that old data is cached by browser ( which is less possible ) or by some proxy or joomla extension ( more possible )

b) domain problems - the scheduler page need to be loaded from the same domain as it was defined in joomla’s configuration. So if you have two domain names pointing to the same site. Scheduler can work for one name and not work for another. ( caused by cross domain security rules in browser )

Could you explain a little Stanislav?
The cache was cleaned and all browsing data removed
In safari on the macs and ie on the xp pc
Still wouldn’t display the events
I even downloaded chrome for Mac and firefox for Mac
Cleaned all browsers caches etc and still no go
Got me stumped even how I got it to work on one of them
I tried today and nothing I did would display the events
Yet when I looked at the site through my wireless laptop
Which is nothing to do with their network it worked perfectly
So it cannot be a cache issue as caches were clean
I don’t follow the proxy issue when I got it to work somehow until reboot
And joomla extension? The only extensions I have there are high slide log in
Scheduler and the map ext. The rest are running in an frame.
One thing that does happen , it’s like the events just won’t load
When I click on the scheduler menu button it loads the scheduler
Then a warning box pops up with nothing in it but the URL
Eg. Triangle with a ! In it and it says beside it
The site at says?

With no error or anything else in the box
If click the x it just takes me to the scheduler with no events showing
Does that tell you something as without an error displaying I can’t work it outs

And as this works on machines outside of their network I don’t understand the cross domain thing . Do I have to set joomla sef to on and edit the config files live site area?
Can you explain?
Sorry for being so dumb but I thought I had it working perfect before trying it on their network
Ps. It’s the same one I pm,d you the info on a while ago

Does that tell you something as without an error displaying I can’t work it outs
Server side script which must return data outputs an empty text instead. Most probably some php level issue occurs. It can be a problem with php configuration, but I’m not sure how it can load on some computers and not load on others in such case.

Try to enable “debug output” in admin panel, it can result in some more usefull error info , also , the log file will be saved in components folder, which will contain error info, if any occurs.

Also, double-check that domain of server is the same on all computers ( even www. prefix can matter )

I am in work now
I cant access the scheduler component at all on the work computers
Joomla administrator panel works fine
When i click on the components tab and got to ‘Scheduler’ the yeloow loading bar just cycles continuosly ???
So I cant even turn on debug from here as I cant get into it .
I should have checked this first but it seems the scheduler wont load in the admin section of joomla/administrator …Does that help with any ideas???

Update :- Did A clean install of joomla with no sample data
Installed scheduler
Set up a few fields
Then went to front end to see what happens ( On the work computer )
And it does the same thing
The error box comes up with the same as before
error= ! The site at says?

then nothing
events wont save cause that error above keeps popping up
Although I can access the scheduler in the joomla administrator panel now
So No idea …

Put my orig build back on and can only get it to work in google chrome for MAC by disabling the popup blocker when it asks ( add my site to the allow list ) so i guess chrome it is …
Still cant work out why ff and safari will show everything but wont load the events and i get that stupid empty error box .
Anyway , ran in debug mode with a clean scheduler-log file then added one event ( from home where i can get it to work )
The attached file is the result (715 Bytes)

If app doesn’t working for all computers - it means that server side is broken. But if it works only for part of computers - it means that they request data differently and not all can retrieve data.

The possible reasons

a) cross domain security
b) blocked httpreques component in IE
c) blocked read access on scheduler’s level ( admin panel, access settings )

Is the url which you are using to access scheduler and url which set in joomla’s config as site url are the same?

Yes urls are the same
var $live_site = ‘’;

Check sources of generated pages for working and not-working pc - it must contain

scheduler.load(… some url here …);

Is it the same for working and not working case?
Try to load such url in the browser - it must result in valid XML output.

Thanks Stanislav
Yes it was exactly that . Found it after my last post . Seems that safari and firefox kept putting www. in front of the url which was breaking it . If the url is it works fine
When its it wont display . So its all sorted now .
How would I go about making it able to work on both www. and whithout www. ?
Thanks again . Got a bit confused about the cross domain reference but worked it out in the end :smiley:

Due to security reason script can operate only with data feed from the same domain. And scheduler uses site address which is defined for Joomla.

The simplest way - use a single domain for site ( with or without www ) and redirect users which tries to access differently named site with url rewrite rule in .htaccess

Are you have problems only with admin panel or with both admin and public parts ?

I dont have any problem now . The admin section of scheduler wouldnt load if address was www. neither would the events . But alls good now that I know to strip out the www.
And thanks for the tip on the url redirect . Didnt think of that :smiley: