first_hour and last_hour do not apply to the timeline view?

Why would this be? Can this be fixed?

It looks as though we have a choice of showing a horizontal time interval of 9:00 - 20:00 or showing an interval of 24 hours. And there is nothing else?

We want to show a half-day in the timeline view and we will have a link to move the interval up or down. This seems an obvious bit of functionality for the timeline to have.


Timeline view have a greater control so first_hour and last_hour options don’t work. With the configuration you can make any hour first one and the last one. What seems to be the problem?

Best regards,

You say “With the configuration…”. What does that mean? I thought that if I wanted to see a timeline view and set the horizontal axis, for example, from 12:00 to 16:00 instead of from 09:00 to 19:00, that I would do this by setting the first hour and last hour parameters. This seems to be the obvious variables to use to configure the view in the way that I desire. I thought I could configure the view by setting the parameters.

How do I configure the timeline view to see the hours I want to see on the horizontal axis?


Please check following sample:

x_unit: "minute", x_date: "%H:%i", x_step: 30, x_size: 24, x_start: 16, x_length: 48,
Unit is minute, step = 30, start = 16. 16*0.5 = 8, so the first hour is 8

Kind regards,

It looks as though this will work. We will see.

It is certainly less obvious than using a first_hour and last_hour parameter. If you all could add the first_hour and last_hour parameters to the timeline view, it would be a good thing.

Perhaps you can add to this document: … first_hour … .last_hour

You could point out that these are not available for the timeline view but that the equivalent is possible using the method you have provided to me.

Thanks for your response.

cheers - ray