First row not selectable with click

DHTMLX Pro version 5.0.2
I have a grid made for tablets so the gui is big in general.
However, the first line in the grid (and sometimes the last line) is not selectable with a mouse click.
I can select it by code and by the arrow keys on the keyboard.

[code]gMtrlListGrid = gMtrlListLayout.cells(“b”).attachGrid();

gMtrlListGrid.setHeader(",Benämning,F.plats,Satsnr,   Antal,Att plocka,Slut,Status,Track,ID", 
        ["", "", "", "", "text-align:right;", "text-align:right;", "text-align:center;", "text-align:center;", "", "text-align:right;"]);
gMtrlListGrid.setStyle("font-size: x-large;", "font-size: x-large; height: 46px;", "", "");


gMtrlListGrid.setColumnHidden(cMtrlTrack, true);
gMtrlListGrid.setColumnHidden(cMtrlId, true);[/code]

vRowID = gPlockGrid.getSelectedRowId();

It seems like when the vRowID is “0” it is not possible to select it by a mouse click. It doesn’t matter if the rows a sorted in another order in the grid this row is still not selectable.
I’ve tried changing the skin and removing all formatting in the rows.

dhtmlx component can behave incorrectly if you are using such ids as 0, null, false ( it is caused by core js behaviors, where 0 is equal to a logical false )

I’m not setting this id to anything. I thought this was something dhtmlx handled internally. How are you supposed to do?

I tought that RowId never is 0 but always start at 1. colId start at 0.

I have a grid with only 1 cell. if I want the value I use myGrid.cellById(1,0).getValue();

I hope this can be of any use to find a solution

This seems to work:

for ( i = 0; i < vRows; i++) { gPlockGrid.addRow(i, i); gPlockGrid.cells(i, 1).setValue(vGridArrays[i].produnit); gPlockGrid.cells(i, 2).setValue(vGridArrays[i].wo); .... gPlockGrid.setRowId(i, i + 1); // <- Added }


for ( i = 0; i < vRows; i++) { gPlockGrid.addRow(i+1, i); gPlockGrid.cells(i, 1).setValue(vGridArrays[i].produnit); gPlockGrid.cells(i, 2).setValue(vGridArrays[i].wo); .... }