Grid header hides page elements


#1

Grid header always appears on top of other page elements. How can I prevent this?


#2

Please, try to enlarge the z-index of your elements, or you can change the z-index of the grid header:

.dhx_footer-wrapper, .dhx_header-wrapper{
   z-index:21
}

#3

Setting .dhx_header-wrapper{ z-index:0 } fixed the problem!
Could this break other grid functionality?

Thanks a lot sematik.


#4

Enlarging the z-index of your menu on a page would be a cleaner solution.
Also, a “0” value is not the best one, because it will break the the grid data displaying:
https://snippet.dhtmlx.com/4ka3qevd (try to select a second row and scroll the grid to check the issue).
Setting z-index at least to “11” will solve this problem, but I still recommend you to enlarge the z-index of your menu elements.