Grid retreives manualy added record but not add or delete

I’m able to retrieve records but not add or delete

When I add for a second it show the row but disappears.

When I change the submit to delete it crosses out the selected record, but then oddly reappears like nothing happened.

What am I missing?
(I did some minor editing of my example below so I could publish it, but it’s basically copy and past from the browser and I am seeing a row of data)




Add Delete Selected Row

table (tried with reminder_id as autoincrement too)

CREATE TABLE reminders (
reminder_id int(11) NOT NULL,
date_due date DEFAULT NULL,
user_id int(11) DEFAULT NULL,
date_set date DEFAULT NULL,
priority char(1) DEFAULT NULL,
reminder_title varchar(45) DEFAULT NULL,
division varchar(2) DEFAULT NULL,
canceled int(1) DEFAULT NULL,
ical_flag int(1) DEFAULT NULL,
email_flag int(1) DEFAULT NULL,
notes varchar(245) DEFAULT NULL,
PRIMARY KEY (reminder_id)

mysql> select * from reminders\G
*************************** 1. row ***************************
reminder_id: 2
date_due: 2012-01-01
user_id: NULL
date_set: 0000-00-00
priority: 1
reminder_title: new title
canceled: 0
ical_flag: 0
email_flag: 0
notes: NULL
1 row in set (0.00 sec)

<?php // data_test.php require_once("connector/grid_connector.php");// includes the appropriate connector $res=mysql_connect("myip","root","mypass");//connects to a server that contains the desired DB mysql_select_db("mydb");// connects to the DB. 'tasks' is the name of our DB $conn = new GridConnector($res,"MySQL");// connector initialization $conn->render_table("reminders","reminder_id","date_due,priority,reminder_title,division,canceled,email_flag,i cal_flag");// data configuration ?>

I even had the same type of issues when I pointed it to CodeIgniter. Could retreive data and noticed it firing in the update function, but it never entered the insert or delete functions?

But want to figure out the core issue with the code 1st before complicating my issue.


The dataprocessor can’t remove the newly added row on its own.
It is possible that pressing the button triggers page reloading, so you have both data saving call and page reloading call, which causes the above effect.

Not quite sure, but you can try to remove “form” tag, or move buttons outside of it, to prevent form auto-sending.

I will try that thanks


Good observation. Took out the form tag and it worked. Yay!