Grid To Excel generates blank page

Are there any special requirements for php server or its configuration for this function to work?
Our both (testing - 5.2.5 & production - 5.0.5) servers act the same - it generates blank page.
When listing POST parameters in generate.php it shows that grid_xml is empty.
Whether or not I enable debug in generate.php, it never creates any error*.xml file.
When I switch from local generate.php to one at the function works ok.
Thanks for any help.

it shows that grid_xml is empty
It seems that problem occurs on client side, while sending grid’s data
If data is not coming to the PHP script - all further processing logic is useless.

When I switch from local generate.php to one at the function works ok.
That is very strange, because the generate.php at takes data from the same POST variable. Can it be possible, that some server configuration on your PC interfere with POST request and clearing part of data from it ( some proxy, mod_replace settings probably) ?

Also, you can try to update your version of grid_to_pdf from the next package …

Thanks, this works now.

Client side was ok, the parameter was sent as it should be, I just failed to see it (with print_r function).

The problem was on the server side. PHP 5.0.2 on our production windows server is not compatible with PHPExcel classes. I enabled error reporting in gridExcelWrapper.php and saw errors regarding IteratorIterator class from PHP SPL, google solved the rest.
After upgrade to 5.2.13 it works.
Some links: … +not+found
Maybe you could verify this info and put it into documentation as a requirement.

And, to have more fun, I tested this on our testing server which has the required PHP version and SPL is compiled and enabled, but it failed to generate file, because the script halted on error_log function when debug=true… :slight_smile:


I had proplem that GridToExcel generate empty page, too. If I use smaller grid data, all is fine.

I resolve proplem with next line at begin generate.php on server side script

ini_set(‘memory_limit’, ‘96M’);