Grid to Grid & dataprocessor

I am having problems using drag and drop between grids using dataprocessor.
I have two grids linked to the same data file on the server.
I can insert/update/delete on each separately, but am having difficulty dragging one to the other. The record is removed from the source grid, but there is not data process on the target grid. I have tried manipulating the gridToGrid method, but am still having difficulty getting it to work seamlessly. I prefer not to re-invent the wheel, as I am sure that I am missing something.
Is there any detail samples? I have gone thru the documentation over-and-over and can’t seem to find the solution.

Thank you in advance.

I seem to have solved my issues. I misunderstood the purpose of gridToGrid functionality.
All drag functions work now.
However, when dragging a row from one grid to another, instead of replacing the row in the target grid, it adds it. I know there is a way to replace the grid, but am unsure of which method to use.