How to fix this gap problem for Export to PDF??

Image of problematic schedule

I am trying to figure out how to fix the gap problem highlighted by red and green arrows on the image linked above.

This is a weekly schedule and each event has a pre-determined (on event creation) start and end times (morning, afternoon, and evening). Each day has at most 6 events (2 stacked side by side to denote front section or back section for that time period).

Only change I made to the generate.php for Export to PDF is adding these:

$scPDF->dayEventBodyFontSize = 6;
$scPDF->dayLeftWidth = 0;

I wanted smaller text and to get rid of Y-axis (time scale). No other changes has been made.

I appreciate any assistance to help me fix the gap problem.

We can’t confrim the issue, after making the same changes from our size - pdf render still works correctly.

Just to be sure - please try to update export code with attached one ( latest version ) (630 KB)

Hi Stanislav, I downloaded those attached files and it hadn’t fixed my problem. But I may have figured out how to fix it.

I had these parameters set for the scheduler shown in the image in first post.

scheduler.xy.scale_width = 0;
scheduler.xy.menu_width = 8;

However I was wondering if these parameters were the culprit, so I changed them to:

scheduler.xy.scale_width = 50;
scheduler.xy.menu_width = 0;

It turns out the pdf schedule is fixed!

But I want this parameter so that I will have some room on the scheduler to click on so I can make the lightbox appear within the time period. For example:

scheduler.xy.menu_width = 8;

With the parameter above, I get this schedule in the pdf:

It seems that scheduler.xy.menu_width is making the event blocks in the scheduler pdf fatter than it is. I’m curious if it is an issue with the css and if it can be fixed?

Thanks for assistance.

Could I have some assistance with my issue please?

here is a fix. You should update file dhtmlxscheduler_pdf.js from attachment. (2.83 KB)

Thanks radyno. That fixed my issue.