I want to disable auto reposition of x-axis (;


#1

Hi!!!

When I select some row in scheduler(displayed in gantt’s left side), the x-axis of the table move to target’s appropriate position. it seems that the target’s left css style fit to the left side of gantt’s out layer.
so, I wanna disable these auto movement about a-axis.(not y-axis. It’s good about moving to target’s y-axis when click some tasks)

help~~ thanks!


#2

Hello,
If I understand you correctly, you click on a task row in the grid (left part of Gantt), then Gantt scrolls the timeline (right part of Gantt) to show the task.
If you want to disable that behavior, you need to disable the scroll_on_click parameter:
https://docs.dhtmlx.com/gantt/api__gantt_scroll_on_click_config.html
Here is an example of how it works:
http://snippet.dhtmlx.com/5/801cfc324

If you need something different, please, describe your question in more detail. Also, you can send me a picture that shows how you imagine it should work.


#4

Gooooooooooooooooooooooood!!! Thanks!!!