Import file to Gantt but Baseline Duration disappear

We uploaded .xml file to Gantt and found that DHTMLX sever
Server Responsed but there is no baseline Duration ( empty Array in custom Data) *https://export.dhtmlx.com/gantt

any suggest

Hello Varit,
I tried to import the following file that has several Baselines:
https://files.dhtmlx.com/30d/49b317a318ef0dc9153815fa5bc50769/baseline_properties.xml

The Baselines are imported:


https://snippet.dhtmlx.com/ng622ah7

If you can reproduce that issue in the snippet, please, send me the file so that I can reproduce the issue locally.

Hi,

Thank you for response,
I downloaded your file and test in snippet found out that there was no baseline as well ( Pic.1)
So we tried our file, which attached below, and found out the same result (Pic.2)
Master Schedule Enter_Site Around_Rev2.xml (1.2 MB)

We use Gantt version 7.1 (with React). But your url is api.js version 5.2.0
might be a result that there is no baseline in our side.

if you have any update in this issue, please let me know
Thank you,

Hello Varit,
Sorry, it seems I sent the wrong link. Here is the correct one:
https://snippet.dhtmlx.com/ehwd8x1o

However, the ?v=5.2.0 parameter after the link for the api.js file doesn’t mean that it is for the Gantt 5.2.0 version. Our server has a single file for all versions. The version parameter is ignored. It is only used to tell browsers to download the file that has the same name instead of using the cached version.

The MSP files are converted to the JSON data on the export server. So, Gantt version doesn’t affect the data you receive.

The first task doesn’t have the baselines, but other tasks have it:

I checked your file, and it has the baseline only for the Permit task:

In previous versions of versions of the export module, it was possible to import the Baseline properties, but the Baseline1, Baseline2 and other baseline properties were not imported.
Now, you can import the Baseline1, Baseline2 and other baseline properties, but the Baseline property is not imported.

HI Ramil,

We tested .xml files from your file from previous comment, exported form MSProject and export from Gantt in our app. attached here
dhtmlx-what-th.zip (702.0 KB)

We found out that test file has 3 baselines. ( Number 0, 1, 2)

but others file has only 1 baseline. ( Number 0 )


So, when we upload to to DHTMLX Gantt in our app. We guess that import service skip baseline number 0.
these issue impact our client,
Any suggest

Hello Varit,
Yes, as I said in the previous message you can import baselines with the number starting from 1: Baseline1, Baseline2 and others. The baseline without the number in MS Project (Number 0 in the xml file) is not imported. Unfortunately, right now, there is no way to import it. I added it as a bug to our internal bug tracker. The dev team will fix it in the future, but I cannot give you any ETA.

Unfortunately, there is no workaround for that bug.

Hi Ramil,

Thank you for your quick response,

if you have any update/new version to fix this issue please let me know

Thank you.

Hello Varit,
We don’t notify about the bug fixes immediately after the update is released, but eventually, you will be notified.