Incorrect configuration for hiding weekends in the timeline


#1

I am using the timeline and I am trying to hide weekends but it is not working properly. All events are pulled outside the view. Can you please help me with the correct settings to display the work week in the timeline in 6-hour steps from 00-24 Monday to Friday?

These are my settings:
step=6
size=28
unit=‘hour’
x_length=28

Then I check in ignore_timeline
date.getDay() === 6 or date.getDay() === 0


#2

Hello Mik,
I’ve checked the timeline view with a hidden weekend in a simple snippet http://snippet.dhtmlx.com/5/52d8a458b, but it seems to work correctly there. All events are rendered in the Timeline view.
Please, check if you specified a link to the section id in the event data and specified the y_property parameter in the createTimelineView method:
https://prnt.sc/r6yyoz
So if you still have this issue, It will be helpful if you reproduce your scenario in our snippet tool (to reproduce your scenario, click the share button and send me the new link):
https://snippet.dhtmlx.com/5/a40beee82


#3

Hi,

Thank you for the answer. I found that I had made a mistake in my code and after correcting it, all was fine.

//Mikael