Internet Explorer error

Working with free version of DHTMLX components at the moment as I evaluate them.

I have the most excellent dhtmlxgrid loaded via php/mysql.

Never could do a window open function from an Excell link type that worked in anything but Safari/Mac but I di manag to set an event to run a javascript function that opens a dhtmlxWindow. “mygrid.attachEvent(“onRowSelect”,function(id){ openw(id);});” which works in Firefox/MAC, Firefox/PC, and Safari/MAC.

So far so good except for one critical problem. The grid doesn’t work in any version of IE that I have tried.

Whenever I try to load the page in IE6 or IE7 (PC) I get the error:

‘this._fillers.length’ is null or not an object.

… and the grid doesn’t display at all.

Any idea?



Whenever I try to load the page in IE6 or IE7 (PC) I get the error:
>>‘this._fillers.length’ is null or not an object.
Unfortunately we cannot reproduce this issue locally. Can you please send us any kind of sample where we can reproduce it?

‘this._fillers.length’ is null or not an object.
It seems that issue somehow related to usage of smart-rendering mode.
You can try to use the attached js file instead of original one - it is the latest version of srnd extension, with all fixes up to date. (2.34 KB)

I’m trying to attach my index.php and getGridRecords.php file. The attach box just stays expanded so I’m not sure if they’ll really be attached…

It works fine in all the browsers I’ve tested except PC-Internet Explorer (v6 and v7)
I get the error

line 609, could not get the align property, invalid argument


line 105, invalid argument (this is new, after using the new .js)

and then

line 139

this._fillers.length is null or not an object.

BTW, I can only reach this page via Firefox on MAC. I tried using Safari and it hangs forever with a “Loading, please wait” message.


Please remove the attachments from my last response. Didn’t realize I was exposing login info. There is no way to edit posts here?

We have removed the attachment


Here are two new attachments. (1.27 KB) (2.39 KB)

I’ve also had weird errors like this after upgrading to 2.5 and I tracked it down halfway to the grid.init() function where it says:

if (this.hdr.rows.length > 0){

What’s happening is that if you init the grid in the wrong place after you set your colTypes, it clears your headers. So I worked around this by removing explicit .init() calls.