libCompiler returns empty files

I can’t get libCompiler to work properly.

I’ve downloaded and installed on a Linux computer in the htdocs directory. PHP is installed and working.

Browsing to amd/dhtmlx/libCompiler/ I see the correct libCompiler layout.

I choose (for example) “Grid Full” and a skin. Click on ‘generate’.

“In progress”, then “Ready code stored at ./export/1284462507”.

If I look in ./export, I see a number of directories similarly named, but not 1284462507. But I click to download in any case, and end up with Opening it, I see a directory ‘imgs’ and three files: dhtmlx.css, dhtmlx.js and manifest.txt. They are all empty files, they have a file size of zero.

Note that ./export/1284462507 still doesn’t exist on the Linux server.

I have tried it on another Linux computer (both running Zenwalk), and with three different browsers on the calling computer (WinXP). I can only assume it’s an installation problem, but can’t imagine what it might be. Would appreciate any suggestions to trouble-shoot this.

I have installed other dhtmlx components individually, and they work as expected.

We have repeated the same process on both win and linux text PCs - it works correctly in both cases.

The only possible reason - in case of linux server you have not write access for libCompiler/export folder - so script can’t create result files.

Thank you, and I appreciate you going to that trouble.

The very first thing I did was to check permissions of each directory. Although they should be correct, as it was a straightout ‘unzip’ operation to create them in the first place.

Both the computers on which I tested it unsuccessfully are on a local net. I’ve since put it on an Internet connected server, and it works just fine.

I guess it’s a PHP configuration issue of some kind, but I’m not going to spend any more time on it. I now have a working installation, which is the main thing.

Thanks again.