Main bottom toolbar buttons become unresponsive

I keep finding that the buttons on the main bottom toolbar become unresponsive, and either need multiple or prolonged clicks. Once they actually became totally unresponsive, and I had to navigate away from the page and come back. The device I’ve been testing on is a Samsung Galaxy W running Android 2.3.5. The other buttons generally behave OK (apart from sometimes the navigation arrows on the day and month view). Is this a known issue with this particular flavor of android or device. The touch screen functionality of the phone is generally very good, and only requires the slightest of touches to click/select something on most web sites. As a side note, I also tried the online demo on my phone with very similar results. Thanks.


we have tested mobile scheduler on devices running Android v.2: buttons work, but more slowly than on the iPhone. We’ll consider the issue. However, most probably it is related to device and browser performance and can not be solved from our side.