Make the time fields optional?


Is there a way to make the time dropdown selectors optional? Some events are “TBD” (To Be Determined) and we would not want to show a time on them. Right now, I don’t see a way to add an event without it having a time on it.

Ideally, there could be a checkbox that would allow us to toggle the time’s visibility on/off for a particular event. (I realize that the event needs to be stored with a time for compliancy to the RFC, but hiding it from public view would work.)

Is this possible?

scheduler.config.full_day = true;

It will add “full day” checkbox to the edit form.


Indeed events need to have some time and they will be showed at that time but you are not restricted to display time section. Check the following sample:


html, body{ margin:0px; padding:0px; height:100%; overflow:hidden; }
[/code] Best regards, Ilya

I am using the WordPress Scheduler plugin.

When I edit the scheduler_include.html file to add the fields you suggest, I do not see anything change on my calendar (like the “all day” event check box, or date formatting, etc)

Here is the script initialization I am adding:


Is there something else I am missing to allow this include to work?

Also, the Admin display (WordPress Admin > Plugins > Scheduler) is blank in IE9, just as a side note.

P.S. - how do I alter the date box in the pop-up event editor to show ‘9-13-2011’ rather than ‘13-09-2011’ ?

Have you added this code in scheduler_include.html file?

Yes. No luck. See Attached.

scheduler.config.hour_date you may configure in admin panel.
Another options should work. But there are some moments:

  1. you’re trying to use new features which aren’t available in scheduler version in Wordpress package. Try to update scheduler codebase. Don’t forget to make backup. I’m not sure if this update will decide all problems.

  2. You’re trying to use features from extensions. So you have to add corresponding extensions at the same file. For example:

<script type="text/javascript" src="dhtmlxscheduler_minical.js"></script>
<script type="text/javascript">

   scheduler.templates.date_of_end ="%m/%d/%Y");
   scheduler.templates.calendar_time ="%m/%d/%Y");

   scheduler.config.repeat_date = "%m/%d/%Y";

   scheduler.config.hour_date = "%h:%i %A";
   scheduler.config.full_day = true;

I have the Scheduler code updated to 2.3.1 and see the “Full Day” checkbox, but the box label says “Undefined”.

Is there a language file somewhere that needs to be updated?

Open file wordpress/wp-content/plugins/event-calendar-scheduler/codebase/dhtmlxSchedulerConfigurator.php and modify it like here:

if (strlen($locale) > 0) {
			$scheduler .= "<script src=\"".$url."sources/locale_".$locale.".js\" type=\"text/javascript\" charset=\"utf-8\"></script>";
			if ($settings['settings_repeat'] == 'true') {
				$scheduler .= "<script src=\"".$url."sources/locale_recurring_".$locale.".js\" type=\"text/javascript\" charset=\"utf-8\"></script>";

Perfect. Thanks.