I was wondering if the naming for the odd row is wrong in the rendered view and material skin css.
I was trying to overwrite the background-color for .gantt_row .gantt_task_row but no matter what I change, it doesn’t work. I tried to track down, and it seem to me the class name is wrong? See below.
If you see the page source, it is stated as gantt_row_task.
And if you see the source of dhtmlxgantt_material.css inside skins directory, there is no gantt_row_task, only gantt_task_row
You need to use
.gantt_row.gantt_row_task. It should work the same way for the material skin and for the default, terrace, skin. Here is an example:
Please, clarify you tried to apply
.gantt_row .gantt_task_row to colorize rows.
Thanks for clarifying.
I was using .gantt_row_task previously as mentioned.
Let me try to use .gantt_task_row and see if it works and get back to you.
I have tried and it works.
So I’m using
.gantt_row.odd,.gantt_task_row.odd to adjust the
background-color of the row accordingly.