а

Need to upgrade DHTMLx libraries for salesforce


#1

Hi All,

We want to upgrade our DHTMLx libraries to latest 6.1.3.Could you please provide me document that help me upgrade these libraries in salesforce.

Regards,
Sheetal


#2

Hello Sheetal,
The latest version for the current date is 6.2.7. But unfortunately, starting from the 6.2.4 version, Gantt doesn’t work in the Lightning Aura component. That bug will be fixed in the future, but I cannot give you any ETA.

To update Gantt in Salesforce, you need to use a prepared zip archive with Gantt. The root of the archive should contain all files and folders from the codebase folder.

Then you need to upload that archive in Salesforce. Follow these steps to do that:

  1. Click on the gear icon and choose the Setup item.
  2. Click on the Custom code list
  3. Select the Static Resources item.
  4. Click on the Edit link near the gantt application.
  5. Upload the zip file.

#3

Thanks Ramil. I will check and confirm