No scrolling when using version 5.1.0

I just upgraded my Gantt to from version 4.2.1 to 5.1.0 and I lost the ability to scroll.

I have tried everything from a custom config layout to removing parent

elements but nothing works. It instantly works if I downgrade back to 4.2.1.

Anyone else seeing scrolling issues?

I checked how the code written for 5.1 version works in 4.2 version. And looks like that versions have different layout config settings. Please check the following examples:
Those snippets have the same code, the difference is only in Gantt version. You can try to add a column several times using the button and you’ll see that in the 5th version the scrollbar appears while in the 4th version it does not appear.

You can read more about config settings in the following articles: … onfig.html … onfig.html
If that doesn’t help you I need a sample of your code to see what might be wrong. You can modify the snippet above. After you edit the code and see that it reproduces that there is no scrollbar, click on the “Share” button and copy the link for the snippet.

I have tried all that even not setting a layout and using the default. I never get scrollbars with either version (on the Mac), but at least version 4 lets me scroll with the touchpad.

It is hard to guess what kind of problem you have without a sample of your code.
If you share all your code in the snippet (you can remove any important data) or send the html page with all necessary javascript code, I will try to find what might be wrong in the code and fix it.