Not all events are rendered - Solved


#1

The data feed contains events that are not being rendered on the timeline.
Each one is formed correctly, all fields are filled in and the section ids are correct.

There are four events that each have their own ID and section number like this example:

id: 719260
start_date: “2021-02-08 00:00”
end_date: “2021-02-13 00:00”
text: “Swim Class”
section_id: 668973
schedule_type: 6
readonly: 1

Whichever event is located first in the data feed is rendered and the others are omitted from their section.

Any help is appreciated.

Thank you.


#2

It’s going to be nearly impossible to figure out what’s going on without either code or raw data to look at. Based on what’s here, the first thing I’d check is a very-very detailed look at the raw data (JSON?) and make sure there’s not a mix of single and double quotes causing a problem.


#3

Hello @jwood ,

The described behavior occurs if few events have the same ID, so only the last parsed event will be displayed. But as you mentioned that they have different id’s, it’s probably not your case.
As @kcasarez mentioned above, it’s hard to suggest why some of the events don’t render on the scheduler without examples of the data, and scheduler config in which the issue occurs.

I tried to reproduce the issue with provided event’s data, but it renders correctly:
http://snippet.dhtmlx.com/5/a167b072e

Could you please provide detailed instruction on how to reproduce the issue, or reproduce it in our snippet tool(open the snippet above => reproduce the issue in HTML/CODE tabs => click the “Share” button?


#4

Thank you @kcasarez, going over the formatting with a keen eye helped. It did not correct the issue but we corrected another we didn’t know we had.


#5

@Siarhei on further inspection, it is the ID field causing the issue on our live server.

We have an event builder that allows you to create and assign people (sections) to the single event and we then display the event for each person. The live server is using the event_rid as the ID, causing the duplicate.

Thank you!