NotFoundError for Material skin


#1

using Terrace skin works fine but trying to use Material generates error popup:

NotFoundError: Failed to execute ‘insertBefore’ on ‘Node’: The node before which the new node is to be inserted is not a child of this node.


#2

Hello @dstaviss,

I tried to reproduce the issue with “Matertial” skin in our snippet tool but it works correctly:
http://snippet.dhtmlx.com/5/eb4d80809
The issue could be related to some additional config or custom functionality, but it’s hard to suggest what exactly goes wrong without more details.

Could you please provide me instruction on how to reproduce it, or reproduce it on our own in our snippet tool?
Steps:
open the snippet above => reproduce the issue on “HTML/CODE” tabs => click the “Share” button => post here the new link


#3

I think I figured it out on my own - the dhtmlxscheduler_material.css was not deployed to the webserver and that confused the js. This is a bit odd that missing css can cause js errors, and raises question about the design of the software that can’t be diagnosed based on the detailed errors… but worked anyway…
Thanks, David