Possible Bug: Parent Control does not show in Lightbox

Hello everyone,

I tried to implement a Parent Control in my Lightbox, but nothing shows up. I have copied the code from the example http://docs.dhtmlx.com/gantt/samples/05_lightbox/08_parent_selector.html with no effect.

Strange thing: if I just change the type and name parameters, the control works. So when I change from Parent- to Type Control, the Type Control shows up.

Btw, in the Guide http://docs.dhtmlx.com/gantt/desktop__parent.html, you initialize the Type- instead of the Parent Corntrol :wink:

gantt.locale.labels["section_parent"] = "Parent task"; gantt.config.lightbox.sections = [ {name:"description", height:38, map_to:"text", type:"textarea",focus:true}, {name:"parent", type:"parent", allow_root:"true", root_label:"No parent"}, {name:"time", height:72, map_to:"auto", type:"duration"} ];

OK, it IS a bug, as even in the “Parent selector” sample the Control does not show up in the Lightbox. At least not if I run the unmodified sample on my local Web server. Just out-of-the-box /samples/05_lightbox/08_parent_selector.html does not work :frowning:


we’ll fix code sample, thanks.

I can not confirm the problem. The control seems working correctly online
docs.dhtmlx.com/gantt/samples/05 … ector.html

and with package v2.1.1 that can be downloaded here

Can you show your code, or attach a sample html page?

Hello Aliaksandr,

just downloaded the V. 2.1.1 again, still the same problem. I placed the original sample in the .zip (as I am not allowed to attach .html files).

I also added all the code I use. In myGantt.html I connected a Gantt with a Grid. Because of this, I have two .php files connecting each to the DB, which has these two two Tables:

DROP TABLE IF EXISTS `gantt`.`gantt_links`; CREATE TABLE `gantt`.`gantt_links` ( `id` int(11) NOT NULL AUTO_INCREMENT, `source` int(11) NOT NULL, `target` int(11) NOT NULL, `type` varchar(1) CHARACTER SET latin1 NOT NULL, PRIMARY KEY (`id`) ) ENGINE=InnoDB AUTO_INCREMENT=6 DEFAULT CHARSET=utf8;

DROP TABLE IF EXISTS `gantt`.`gantt_tasks`; CREATE TABLE `gantt`.`gantt_tasks` ( `id` int(11) NOT NULL AUTO_INCREMENT, `text` varchar(255) CHARACTER SET latin1 NOT NULL, `start_date` datetime NOT NULL, `duration` int(11) NOT NULL, `progress` float NOT NULL, `sortorder` int(11) NOT NULL, `parent` int(11) NOT NULL, `deadline` datetime NOT NULL, `display` tinyint(1) NOT NULL, PRIMARY KEY (`id`) ) ENGINE=InnoDB AUTO_INCREMENT=29 DEFAULT CHARSET=utf8;

So now you have all I am working with, but the table entries. Which I hope don’t matter :wink:

Gant_Parent.zip (3.04 KB)

OK, this is strange. If I run the example on the Web Server, it doesn’t work. If I run it without the Server started, it works just fine :question:

Doesn’t work:

I use standard XAMPP- and Apache Settings for my local Web Server.

I can not reproduce it locally, both pages from your package shows parent control as expected.
Can you provide online demo?

btw, if it works from file, probably the issue is related to the data you load to the gantt