Problem with www. , LoadXML and Joomla


I have installed com_scheduler and I have a little matter.

  • If I access to my site with url : , there is no probem.

  • If I access with :, I have a dataXML error.

I check the $live_site in configuration.php and it’s correct (

I want to redirect to with the following code but with this matter, I can’t.

#RewriteCond %{HTTP_HOST} !^www\.mysite\.com [NC] #RewriteRule (.*)$1 [QSA,R=301,L]

Have you got a solution ?

little more information :

If I try to go to … _scheduler , I have an alert and settings don’t load but with www. it works (inverse of the frontend) :frowning:

it’s very strange, can you help me?


In above code snippet you have rewrite rules commented - just to be sure that you have tried the same settings without comments mark :slight_smile:
Locally the same redirecting rule works correctly and doesn’t cause any issues.

Scheduler uses Joomla’s settings to obtain http path to site, and use that path for data loading operations. If paths in joomla settings differs from actually used path - scheduler will not be able to load data.

I’m having the same problem. I checked the Joomla configuration.php and used mod rewrite but I still can’t get the scheduler to load the data.
It does work perfectly without www. in the url.

Where does dhtmlxscheduler set the url it uses? Can I just put the url in the code?
Or do you know where Joomla gets the url from (it isn’t in configuration.php)?


  1. Does the $live_site in configuration.php contain www in url?
  2. Does the redirection occurs when you open another page (not scheduler front page and not scheduler admin page) without www?

Best regards,

  1. Yes
  2. Redirection seems to be the problem. I thought it worked, but now I’ve seen that I was clicking on a menu item which points to the index page on the www. subdomain. After this I was just browsing on the www. subdomain. When I avoid clicking on that menu item, I keep browsing in the subdomain.
    mod_rewrite is enabled according to phpinfo() and in the Joomla General settings the use of mod_rewrite is enabled too.

What am I missing here?


To find more information about your mod_rewrite and redirection process try to add the follow options in apache configuration file https.conf:

RewriteLog "path_to_apache/apache/logs/mod_rewrite.log" RewriteLogLevel 10

Then open your page which must be redirected and in log-file you can find information about redirections warnings, problems and pattern matches.

Best regards,