problems with component "text" and "input" in android

Hi!!! I have a problem in Android. when I write in a text or input ,keyboard is displayed but when I press a key just me out. I can´t write. This problem occurs in Android, iPhone and BlackBerrry works well.
the code is:


var ancho_pantalla=window.innerWidth; var alto_pantalla=window.innerHeight; var mitad_ancho_pant=(ancho_pantalla)/2; var mitad_alto_pant=(alto_pantalla)/2;

var currentTime = new Date();
var month = currentTime.getMonth()+1;
var day = currentTime.getDate();
var year = currentTime.getFullYear();
var today = day + “-” + month + “-” + year;

		{       id: 'layout_a', 
			view: 'layout',
				height : "auto",
				width : "auto"
			rows: [
					{ view: 'layout', type: 'clean', scroll:true,
					rows: [
						{ view: 'label', label: '<h  id="textocabecera">Control</div>', id: 'control_label_2'}, 
						{ view: 'text', label: "label1", placeholder: 'a', labelPosition: 'left',inputWidth:ancho_pantalla, labelAlign: 'left', type: 'number', id: 'campo1',labelWidth: "100"},
						{ view: 'text', label: "label 2", placeholder: 'b', labelPosition: 'left',inputWidth:ancho_pantalla, labelAlign: 'left', type: 'number', id: 'campo2',labelWidth: "100"},
						{ view: 'text', label: "label 3" ,placeholder: 'c', labelPosition: 'left',inputWidth:ancho_pantalla, labelAlign: 'left', type: 'number', id: 'campo3',labelWidth: "100"},
						{ view: 'datepicker', label: "label 4", popup: '', click: '', value: today, startOnMonday: true, navigation: true, weekHeader: false, weekNumber: false, skipEmptyWeeks: true, dateFormat: '%d-%m-%Y', calendarMonthHeader: '%F %Y', calendarDayHeader: '%d', calendarWeek: '%W', cellAutoHeight: true,iconCss :false,  id: 'date_field',labelWidth: "130"},
				{ view: 'layout', 
				type: 'clean', 
				cols: [
				  { view: 'button', label: 'boton1', popup: '', click: '', css: '', id: 'boton_a',inputWidth:mitad_ancho_pant,type:'round'},
				  { view: 'button', label: 'boton2', id: 'boton_b',inputWidth:mitad_ancho_pant,type:'round'}




thanks, and apologies for my bad English :smiley:

I am here again, if I click on the text or input a second time it let me write.why does this happen?


I have a problem in Android.
Please provide a name of device and version of OS


Sorry. I’ve tried to Gingerbread(2.3) in a Samsung Galaxy s, Samsung Galaxy s2 and htc magic. I’ve also tried ice cream sandwitch(4.0) in a samsung galaxy s. iphone and blackberry works well.


I have the same problem, When I click in a textfield the keyboard appear and dissapear in one second, and I am unable to write anything (android 4.0.3). Someone find a solution?