Professional 2.5 appears to Active Content

We recently downloaded the new version of dhtmlx and it seems the code is no longer just Javascript. Is this true? When I run Grid examples in IE, I get a warning asking me if I want to allow “Active Content” to run on my browser. Then because of this, it won’t run at all on Firefox. Is there something I’m missing???


Is this true?
No, it’s not true. dhtmlxGrid is still fully JavaScript component. Just launch example from http server.

I understand your answer that I should post the documentation on a server and this is okay, but I’m still curious. 

What is the Active Content doing that runs when you launch the documentation locally?  Is there a way to disable it?



The component uses AJAX routines to fetch the data from the server. In case of IE it means usage of MSXML active-x object
This component is signed by microsoft as safe one, so it is enabled for scripting by default, but when page is loaded from local drive , IE uses more string security settings, which blocks any components.

The same situation will be actual for any AJAX based component|framework.

IE8 will show such warning for any page loaded from local filesystem which has at least a single line of javascript. And main page of documentation contains a single onclick handler for search form , which is causes a warning message.
We will look how it can be changed to prevent similar warning in future.

Since you’re looking into this for future release, you might like to know that when viewing the documentation locally on IE, when you navigate to the following samples page:  C:\dhtmlx_pro_25_location\dhtmlxGrid\samples\index.html, when you then click to view any of the samples, it opens up Windows Explorer because when browsing locally, it doesn’t know that it should default to opening index.html.  This is a big pain for someone like me who views the documentation locally on my development box. 

FF won’t run and IE opens Windows Explorer. 
Thank you for looking into solving this for future releases,


it opens up Windows Explorer because when browsing locally

Sorry for inconvenience, we really missed this point.
Repacking documentation is quite complex process - so updated packages will be available in few days.

Thank you very much!!