Resource view skipping cells when using subscale with step


#1

We are using the resource view, and we also have the zoom plugin configured. We just started using a subscale with unit ‘hour’ and a step of 8.

This works as expected, except when there is a task which crosses the line of a Daylight Saving Times.
When changing the subscale step from 8 to 1 everything works as expected. Or changing the task so it does not overlaps a DST period.

See this example.
http://snippet.dhtmlx.com/5/cdbb58b1e

Wrong, missing cell values.

Correct, when changing the start so it does not overlap a DST


#2

Hello Henro,
Thank you for letting us know about that issue.
It seems that the template is not called at all. If you enable the resource_render_empty_cells parameter, the template will be called for all cells. But after the timezone is changed, you get an empty array in the tasks argument,

I added it as a bug to our internal bug tracker. The dev team will fix it in the future, but I cannot give you any ETA.