Scheduler & DST.

Hello all,

Is there any way to disable DST on Scheduler? I’m trying the online demo and when DST starts (10/15/2011) here in Brazil, demo cannot skip to next week after DST begins.

On last year, we have the same problem reported at this forum (viewtopic.php?f=6&t=15551). This a bug occours when Daylight Saving Time starts.

Thank you.



Thank you, I can confirm this issue. We are looking into it, I will post updated files.

Kind regards,


I’ve attached updated version of dhtmlxscheudler.js file (and it’s debug version).

Kind regards,
Ilya (58.6 KB)


Thank you for your answer. I’ll try your version. I’ll post news soon.

Best regards,

Luis Fernando

I try to debug your code about DST start, but I can’t fix it.

I do the following to debug:

  1. create a new html with only dhtmlxScheduler elements and setting default view to week.
  2. Config parameter: noy changed.
  3. open dhtmlxscheduler_debug.js provided on this thread and change week_start at line 2556 to:

var shift=date.getDay();
if (scheduler.config.start_on_monday){
if (shift===0) shift=6;
else shift–;
return this.date_part(this.add(date,-1

  1. open a webbrowser e point to my new dhtmlxscheduler page.
  2. click on next week and see dates changing.
  3. when i’m at 10/09 week and click again on next week, I can see that date/time reported by that alert inserted at 3rd step is 23:00hs and not 00:00hs like other weeks.

It is a bug on start DST and I do not known how to work around that.

Can you help me?

Best regards,

Luis Fernando Kieça


Can’t reproduce this bug with updated dhtmlxscheduler.js above.

What I did:

  1. Switched to Brasilia timezone (GMT -3).
  2. Added scheduler.config.start_on_monday = false;
  3. Navigated to 9 October 2011 (Sunday) and clicked Next week button with the breakpoint set to "return this.date_part(this.add(date,-1shift,“day”));" line.
    At this point this.add(date,-1
    shift,“day”) returns Sun Oct 16 2011 01:00:00 GMT-0200 and that’s correct.

Kind regards,