Scheduler in timeline view with x_unit=month- date precision

Hi, I noted some confusing behavor in the Scheduler component when use the timeline view with x_unit = month.

I wrote an example in jsFiddle:

You can see the folowing surprising facts:

  • The Event 1 and Event 2 are shown only in January, but the second one actually ends in February (end_date: “2017-02-01 00:01”).
  • The Event 3 is shown on February, is correct, but no covers all width of February column, seems that the width of each colum has “31 days” and pixels occupied are based on that, although the month actually has 28 days
  • The Event 4 and Event 5 are shown only in Febrary, but actualy starts on February and ends on March
  • The Event 6, is ok: is shown in Febrary and March, i can see differs the Event 5 en the hour end_date.
  • The Event 7 is shown correctly, starts and ends on March and there are no extra espace betweeen march and April, seems is because march is a 31 days month.
  • The Event 8 is shown in April, but there are space extra in the column, seems is becaus april is a 30 days month.

I Tested in Chrome, FF and IE11

There are some kind of configuration option to modify the way the component draws the events to make it to fit the dates with precision?

Thanks in advance.

event are displayed in content-box box-sizing mode … ?v=control , which means that css padding affects widths of event bars.
Event widths are calculated by code depending on time scale settings and event dates, and such calculations consider predefined paddings.
So, reducing horizontal css padding you’ll reduce total width of event bars, currently there is no workaround for this, the one thing that can be done is reducing padding-left while increasing padding-right, so the total horizontal padding stays unchanged, or doing something similar with borders.