Scheduling time not converted to local time


#1

We are trying to upgrade to the latest version ( v.5.3.11), but we are facing a problem with the scheduling time.
It seems that it does not convert from utc to local time (despite the scheduler.config.server_utc = true), setting the scheduled containers always one hour earlier (for example, if we schedule them at 9:30, they will start at 8:30).
We didn’t change anything from our code, so we were wondering if someone else faced this problem.

Debugging the code, I noticed that
scheduler.parse(assignments, "json")
could be the problem. In the version that we were using before, it was changing the utc time to the local one, but now not anymore


#2

Hello @Little_Monkey ,

The only changes in the parse method were in the 5.2 version:
https://docs.dhtmlx.com/scheduler/what_s_new.html#52
which made the “format” parameter optional.

I tried to reproduce the issue in our demo, but it worked correct, which means, that with the server_utc = true; config, the parsed data was converted to the local(+03 UTC):

Here is a demo:
http://snippet.dhtmlx.com/5/04d77cc55

And with server_utc = false; it was parsed as it is(with no changes for local time):

Live-demo:
http://snippet.dhtmlx.com/5/9a2f8183d

Currently, it’s hard to suggest what goes wrong, without details, so could you please reproduce the issue in our snippet tool(open the snippet => reproduce the issue => click the “Share” button => post here the new link), or provide me a step-by-step instruction on how to reproduce it on my end?