Small bar on the left of the event box.


My first feedback from real users is that they would prefer not to have this at all.

I have

scheduler.config.details_on_create = true;
scheduler.config.details_on_dblclick = true;

So the ‘small bar’ only appears on ‘changing events’.

Can I stop this happening ?



Sure, add following:

scheduler.xy.menu_width = 0; scheduler.attachEvent("onClick",function(){ return false; });
That way menu won’t be displayed if user clicks on event and space won’t be reserved for it (so event will take whole column width).

Best regards,

As usual thanks for the fast response - I will try this.

Sorry one other question here:

I already have:


So how would I combine the two things - ‘readonly’ and ‘no menu’ ?

Thanks again

What are you trying to allow here - scheduler.attachEvent(“onClick”,block_readonly); ?
Click action only brings that menu and as you don’t plan to use it anymore I believe you can safely return false and disable it that way.

Best regards,

That is good - thanks