Smart Rendering

Hi, I have a grid that has a download to Excel feature. Since my data has a large volume of transactions, we used the smart rendering feature. However, when we try to download through Excel, it only downloads the rendered rows. We have to scroll down page by page in order for our download to be complete.

Is there a way to disable Download to Excel ALL the records including the unread ones? Like turning off the Smart Rendering feature in the export?

Your response would be greatly appreciated. Thank you very much.

You can export code directly from DB
In such case client side grid will show only part of data, but export link will provide a full dataset as excel file … ata_export

Hi Stanislav, thank you for the resource. I managed to make it work but when I tried to do in actual production data. I have this error inside my downloaded Excel file.

Request Entity Too Large

The requested resource
does not allow request data with POST requests, or the amount of data provided in the request exceeds the capacity limit.

Any other option I can take for larger data? Thanks again.

Would really appreciate your help as we’re now pressed for time to be able to download the entire data in Excel. Thanks again.

It must be caused by server configuration
Check php.ini on the server, the post_max_size parameter. It limits the maximus size fo POST data.