Strange issue with container constantly re-sizing


#1

I recently excluded /ext/dhtmlxscheduler_container_autoresize.js and now calendar container goes berserk every time you switch the view, it starts constantly resizing scrollbars show the are hidden and like this in a loop
No console errors…
Thx,David


#2

Hello @dstaviss ,

Could you please clarify what exactly goes wrong when the container_autoresize is excluded from your project?

I tried to reproduce strange behavior but different views worked correctly:
http://snippet.dhtmlx.com/5/d8fe0d10f

https://recordit.co/xjsGYz4riF

Currently, it’s hard to suggest what goes wrong without more details. Or could you please reproduce the issue in the snippet above(open the snippet => reproduce the issue on “HTML/CODE” tabs => click the “Share” button) and post here the new link?


#3

Hi,
I tracked it down, by trail and error, to a css instruction in my css file:
div.dhx_cal_container
{
display: block;
overflow: auto;
}

I can’t reproduce the behavior in the snippet though as in my code it might be affected by the outer container css which is pretty hard to reproduce as the html is deeply embedded and requires to bring in a lot of stuff with it
Thx, David


#4

Hi @dstaviss ,

In this case, it’s hard to suppose what is the exact issue. But you can avoid random resizing of the container, if you will set its height/width in some fixed units, like:

<div id="scheduler_here" class="dhx_cal_container" style="width:1000px; height:1000px;">

So when the container autoresize extension is disabled, the scheduler won’t change its sizes. In this case, it will be better to remove the “overflow: auto” rule or change it to “overflow: hidden”, as it may cause additional scrollbars(which may be the issue you described):
https://recordit.co/cp1mJO02d3

Demo:
http://snippet.dhtmlx.com/5/a37d5a142


#5

Thanks, I’ve done that and it is now behaving predictably