Tasks won't show up


#1

Hi,

I am using dHtmlX Pro Scheduler with Angular.

I installed the pro version by using “npm install path/to/lib --save” then “npm link”. This seems to be working fine as I am able to initialize the scheduler.

However the tasks are not showing up.

What am I doing wrong here? Everything seems to be the same as in the angular demo. Could it be somehow related to the Pro version I am using, or the way I installed it?

Here’s a sample demo: https://drive.google.com/file/d/12T3dz_8z7MU8y1lzC53QHZZJYDPfnE-M/view?usp=sharing

And the screenshot:


#2

Hello @g2t ,

It’s hard to suggest what goes wrong in your case as if you are able to initialize the scheduler - it means that it installed correctly, and there should be no additional issues, exactly with loading events.

Could it be somehow related to the Pro version I am using or the way I installed it?

There is no known issue specific for the PRO version in comparison to the GPL one.

I tried to reproduce the described issue with the provided demo, and the latest scheduler version(PRO), but it worked correctly:
https://recordit.co/Q4vBdJ4aiL

The thing that I can suggest, is to reinstall the PRO version into your project and check out if the issue will be fixed. Maybe you can use the yarn instead of npm in case to check if the issue could be connected with the exact package service:

yarn add `*path for the package with the scheduler*`

Kind regards,


#3

Hello g2t,

Update for the provided question:

The described issue is could have occurred for 5.1.6-5.2.3 versions of the dhtmlxScheduler, in case of using it with the Angular framework.
The best way to fix it is to use later/previous versions of the dhtmlxScheduler.