There was error during configuration saving.


#1

Hi,

i have a problem after installing the scheduler on my joomla 1.7 website. I want so save configs but there is an error:
// There was error during configuration saving. Last stable configuration restored.
Error report saved to “com_scheduler_log.xml” //

What do i do wrong? Where can i find the log-file?

Thank you for your help!

Best regards,
myashram


#2

Hi,
create log-file should be located in
yourjoomla/components/com_scheduler/com_scheduler_log.xml

Could you provide it?


#3

There is not such a file in that location.


#4

Hello… This is happening to me too… here goes my log file… please could you help me???
com_scheduler_log.zip (365 Bytes)


#5

All,
I am having an issue configuring V3.0 for Joomla. I am (or at least seem to be) able to install V3.0 successfully. When I try and configure Scheduler, I am seeing the same error message as myashram, which is: There was error during configuration saving. Last stable configuration restored. Error report saved to “com_scheduler_log.xml”

As well, there is not any of the default data loaded, as ALL entries are blank.

I checked for a log fine as was suggested by radyno in components/com_scheduler/com_scheduler_log.xml but no such file exists as was the case with myashram.

I have also checked the default.hml file and it SEEMS to have all of the default data listed.

Any suggestions would be helpful.

Thanks,
james\


#6

Hi,
ualvesdias,
do you use any specific components or plugins which may cut xml tags in incoming data during saving settings?

JamesMNelson, does any java-script error occur?


#7

No Java errors noted.


#8

Please, try to press “Restore” button at scheduler admin page. Any changes after that?


#9

I’m having the same problem. I don’t see any javascript errors. No log was created. There is no “Restore” button, but there is a “Default” button. Clicking that doesn’t seem to make a difference.

I’m running my Joomla site on Windows, is it perhaps some sort of permissions problem?


#10

I just upgraded to ver 3.0, same problem I did find a log file within /components/com_scheduler/codebase/com_scheduler_log.xml

attached it. I even tried your suggestion to click default.

I meant to apply this update on a local build first but accidentally updated the live site. Please help.
com_scheduler_log.zip (341 Bytes)


#11

While we are investigating possible reasons of the problem, here the steps how you can restore scheduler’s functionality.

If you can access database

a) locate and backup
joomla_scheduler_options
and
joomla_events_rec
tables ( instead of “joomla” you will have some different prefix )

b) delete all records from joomla_scheduler_options

c) in attached sql code replace table name prefix with one from your database and run sql code. It will reinit settings with default ones, after which scheduler configuration panel must be loaded correctly.
joomla_scheduler_options.zip (1.58 KB)