Timeline click highlight


Since 4.4 when I click/double click a scheduler timeline field it is highlighted. How can I prevent it? I can’t create a snippet for you because docs.dhtmlx.com/scheduler/snippet/ it loads 4.2 version yet.

A video demostration: youtube.com/watch?v=Tr3H7BBeAJc


If don’t need keyboard navigation, you could just remove dhtmlxscheduler_key_nav.js extension.
If you do need keyboard navigation but don’t want to see yellow color. In this case you could try to define “background” css rule for following class: “.dhx_focus_slot”.

1 Like

Hi Dimass,

I’ve sent you an updated build of scheduler, it should fix the issue with ‘isValid()’ error and disabling wai-aria attributes, please check PM

As for disabling timeslot highlight. If i understand correctly you want key_nav extension to work exactly as it was in a previous version of scheduler.
In order to do so, you can hide highlighted time slots, remove new keyboard handlers for arrow keys and restore the old ones.
Please check this code
css, hide time marker and hide focus outline from data-area element:


navigate dates using right/left arrow keys, without disable timeslot navigation:

[code]scheduler.removeShortcut(“left,right,up,down”, “event”);
scheduler.removeShortcut(“left,right,up,down”, “timeSlot”);
scheduler.removeShortcut(“left,right,up,down”, “dataArea”);

scheduler.addShortcut(“right”, function(){
var current = scheduler.getState();
scheduler.setCurrentView(scheduler.date.add(current.date, 1, current.mode));

scheduler.addShortcut(“left”, function(){
var current = scheduler.getState();
scheduler.setCurrentView(scheduler.date.add(current.date, -1, current.mode));

1 Like

Yes, all issues solved! I will update to the 4.4 version on production, thx!