Translate to Norwegian (frontend)


I have translated most of the Calender into Norwegian in the frontpage.
But i cant seem to find where to change “Year” in top of the calender into Norwegian. Se pic.

Is there anyone that can help me with this one??

Regards Terje

I think , that package already includes Norwegian locale

just include it on the page.

Year label is defined in locale as


Hi, and thanx for the feedback.

Its not the tab, but in the middle of the cal. (look pic.)

Have changed year_tab:“År” with no luck. The tab is ok, with translated text


Please try to update js file with attached one, in latest version ( attached ) label is taken from locale for sure (2.68 KB)

Ohh, i am sorry. I use Joomla! so i guess im not using the latest version of the cal. Only the one with joomla (maybee 2.0 version??)


Replace file in com_scheduler/codebase/ext/dhtmlxscheduler_year.js with above attached one.


That file totally blank my year page. Had to get the old one back :wink:


Just have checked dhtmlxscheduler_year.js from the plugins package - it is already uses scheduler.locale.labels.year_tab for “Year” text on top of the calendar.

Are you sure that value was changed in active locale file?
Are changes of other labels in the same file reflected in the view?

It possible that

  • old locale file cached
  • you joomla installation not loading “no” locale, but using some other


All is translated by the local file, exept the “year” in the middle.

check the localefile. (745 Bytes)


Problem was confirmed and fixed.
To update your version - add the next lines to the end of codebase/dhtmlxscheduler_year.js

scheduler.templates.year_date = function(date){ return" %Y")(date); };


That did the trick.

I want to thank you so much.

Im off to write in the about this great component.

Thanx again.


I have downloaded the Norwegian translation. How do I load it in wordpress?

Drop locale file in event-calendar-scheduler/codebase/sources/

Normally plugin takes file locale_{language}.js from it.
Where language is defined by locale settings of WP
If you still have problems - rename file as locale_en.js ( default locale )