Trouble using dhtmlxVault 2.5


#1

Greetings!
Although I have used the dhtmlx products for 10+ years with no jQuery and even successfully used the early vault product, I am unable to get a simple test of dhtmlxVault 2.5 to work. I suspect my problem is in the server side php code, but I am unable to figure out how to debug it. Or, how to show debug messages. I have tried to slim down my test to the minimum, following the example in the doc. I use no Flash or silverlight, just current Google browser.
On the server, I use the included sample PHP, upload_handler. I have uncommented the ‘move_uploaded_file’ statements and have established an uploaded folder on the server.
When my browser links to the html, the download object is properly displayed, I can select a file, the progress bar is briefly displayed that then “Error” is shown.
When using localhost, symptoms are the same but it shows “Done” (but no file is uploaded)
Here is my html:

    <script>
    // init on object on page
    var myVault = new dhtmlXVaultObject({
        container:  "vaultObj",             // html container for vault
      //  uploadUrl:  "server.php",           // html4/html5 upload url
        uploadUrl: "/server/upload_handler.php"
        
    });
    </script>
    </body>

Any suggestions on how to debug this problem (or known good php code) is appreciated.
Thank you and
Have fun
Paxton


#2

I have the exact same problem, and I tried the samples here https://dhtmlx.com/docs/products/dhtmlxVault/samples/01_init_on_page/01_simple_init.html,
and I got the same error like this, and the same on chrome, edge, ie and firefox.


#3

Thanks for the confirm.
I hope you will let me know if you find a solution or ideas on how to debug
Paxton
Paxton@oihelp.com


#4

The problem turns out on the server side php upload handler for my case.
The sample php code for sl mode if (@$p[0] $_REQUEST["fileKey"]) { could have syntax problem.
Files uploaded successfully after this problem is corrected.