Turn Off dhxr extra attribute


Hey all,

It would be swell if I could prevent dhxr from adding a parameter to my GET requests as some external web services don’t take kindly to additional attributes.




we have such plans


Has the ability to turn this off been added?




This request is to add an equal sign between “dhxr” and the number.

Apache requires name/value pairs. This works:


This gives a bad gateway:


People who download dhtmlx to test, if like me, are very skeptical at first that the library works and is error free. Anyone who tries to do any sort of ajaxing with an Apache webserver will get a bad gateway error and might just throw in the towel.

The anti-cache ability is a nice fetcher. It would be nice if it worked in Apache.


Similar fix already was applid in DHTMLX 4.2, now request will look like



That change will be good for apache users. It will be not so good for me as I use oracle mod_plsql and in some cases I need to declare the names of the url parameters. So if the parameter name is always changing, it is a problem.

Also I am using 4.2 and do not see this new change. I will email support to see if I have the newest version.


Adding random elements to the URL is optional, so in case of mod_plsql you can just disable the URL randomization ( if you have a correctly configured server, this anti-caching feature is not necessary anyway )


I am curious why dhtmlx would choose to do this:


instead of


Both achieve the same result with the caveat that the first adds a name to the url which can never be knows before hand.

Is it because you are worried that browsers only look at the url names and ignore values when considering to cache a request? Browsers would be broken if this was the case.

Anyway, not sure who else this would throw off.